Open The Lock explainer


#23

This stage is very basic and understandable. Typically I wouldn’t be here, but on my Samsung Galaxy Note 8, after I set up -

if (foundKey === ‘no’)

I am unable to click after ‘no’ and add the && to check for the pinNumber. Everytime I click string and type no, click done and then click the && button, it then adds parenthesis in the statement, which makes sense… but there’s no seeable option to complete this stage for me.
plz fix


#24

Hey @Rex,

I responded on the explainer thread, but linking here too incase you don’t see it.

Thanks for flagging this feedback,
H :slight_smile:


#25

I am having a problem to solve it. It is continuous telling me that I have deleted some statements. I have done what is suggested but still stack in the same problem.
If (founder === (‘no’ && pinNimber === print (‘you don’t found the key’))
}


#26

Hi @Sambizus,

  1. You have three ( and two ); they must be paired.

  2. === is used to compare two things. You have pinNumber on the left of a === and a command, print, on the right.


#27

It still doesn’t resolve my problem.


#28

Hi @Sambizus,

This was a small bug on our side with the && and || operators: if you tried to enter them with only the last part of an expression selected (such as only 'no' selected, rather than founder === 'no'), the parentheses are applied like the example you shared.

We’ve fixed this now, so if you update the app and try adding && or || again we won’t place them within parentheses. To solve the Open The Lock puzzle, you can also reset the code, and then edit the value; you don’t need to add in && or || — which may have been why you were seeing warnings about some statements being removed.

Hope this helps a little!
H :slight_smile:


#29

oooh I found a typo in this one. (Thanks to my newfound code knowledge. And my eyes ;). I’ll let y’all spot this one!